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1.0 Introduction

The Bid Pricing Tool (BPT) is a group of Microsoft Excel workbooks that organizations use to
develop and submit the pricing components of their Medicare plan bids. The workbooks are
enhanced with special features that facilitate and standardize the bid pricing process. These
instructions explain the special features and other technical aspects related to using the BPT. CMS
recommends that users read this document thoroughly before using the BPT.

The BPT system is comprised of four Excel workbooks. They correspond to the types of bids
organizations can submit to CMS; their filenames, for CY2024 are:

PonhE

CY2024_MA _BPT.xIsm for Medicare Advantage (MA) bids,
CY2024_MSA_BPT.xIsm for Medical Savings Accounts (MSA) bids,

CY2024 _PD_BPT.xlsm for Prescription Drug (PD) bids, and
CY2024_ESRD_SNP.xIsm for End Stage Renal Disease — Special Needs Plans (ESRD-
SNP) bids.

The BPT employs four versions of these workbooks that serve different purposes throughout the
bid price development process:

Working files — are read-write enabled files that allow users to enter data in specified input
fields; bid prices are automatically calculated (in calculated fields) via formulas resident in
the files. Users may edit, save, name, and re-name working versions of the BPT workbooks.

Finalized files — are read-only files created by a process called finalization, which modifies
the format of working files to prepare them for submission to CMS. Finalization converts
formula results in calculated fields into hard-coded values, removes formulas and other
extraneous elements, and saves the file using a standard naming convention. All BPT
functionalities are disabled. The finalized save process will delete or standardize some of
the data in the finalized file according to specified business rules. The finalized save
process will not change the data in the working file. (See Section 1.2.4.1.)

Backup files — are also read-only files created by the finalization process. The backup file
uses the same filename as the finalized file with the word “backup” and a timestamp
appended to it. The data in the backup file is the same as that in the working file; removal
of the text “backup” from the filename will make the backup file editable. As such, backup
files enable users to convert backup files back into working files—if needed—for further
modification.

BPT XML file — An XML file generated from the finalized save process. The file is
generated with a standard naming convention with the extension .xml. The XML file will
contain only data pertinent to upload.

o Example: H1234567123MA.xml.

The XML file is not to be modified after finalization of the BPT and must be uploaded
alongside the finalized BPT .xIsx file of the same name.
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1.1 New Features for CY2024

The following identifies the key changes to the CY2024 BPTs:
1. There are no major updates to the CY2024 MA, MSA and ESRD_SNP BPTs.
2. The CY2024 PD BPT includes
Removal of MTM input (WS1 cells K6:L6).
b. Removal of SSM input (WSL1 cells O6:P6).

c. Adjusted formulas on WS4 and WS5, where needed, to remove Insulin and
Vaccines from original AE tests then adjusted net cost of benefit cells to reach
appropriate totals.

d. Updated 0% coinsurance for standard cost sharing on (WS4 cell 142) / WS5 cell
M45) as there is now no cost sharing in the catastrophic for CY2024.

e. Added a new Actuarial Equivalence test for insulins to Worksheet 4 (cell E62)
and Worksheet 5 (cell G63)

f. Added input cells for Insulin and Vaccine projections (Scripts, Allowed, and
Cost Sharing) to WS6. See Sections 111 and IV (WS6 cells B63:K81).

g. Removed input for WS6 cells H45:H52 ($0 cost sharing in catastrophic).

h. Non-LI Brand Discount Amt PMPM (W6A cell E54) updated to an input cell
for all plan types if plans choose to override formula.

i. New input cells for Non-LI Brand Discount Amount for Insulins/Vaccines
WS6A B56:E57.

j.  Removal of MTM under Summary of Key Bid Elements (WS7 cells B20:B32).

NOTE: Office 365 has introduced a Sensitivity Label feature which allows Sensitivity
labeling to be added to the 365 application suite. The BPTs and BPT add-in will not function
properly if this classification feature has been implemented as part of your organizations
policy for Excel. This feature will need an exception in order for BPT to properly maintain
macro security and execution.
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1.2 Bid Pricing Tool Function

1.2.1 Download and Installation

1.2.1.1 Configuration Requirement

For the BPT to work properly, you must configure your PC to satisfy the following requirements.
BPT is only supported on Windows; it cannot be utilized on MAC:
e Have Microsoft 2016, 2019 or the 365 Offline version installed.
o The BPT will work with either 32 bit or 64-bit versions of Excel.

o The BPT will not work with the 365 Online version. The desktop version of
Office 365 requires a local installation unlike the online version (internet).
The online version does not have the features needed to support BPT.

o The BPT will not work with Office 365 if a Sensitivity Label has been applied
by your organizations’ policy. This will cause the BPT security to conflict
with the label classification and the add-in will not function properly.

o Excel 2013 is not supported.
e Create a folder under C:\BPT\ BPT2024.
e Users must keep the Add-Ins ribbon enabled.

Note: The BPT-specific icons are loaded with the Add-Ins ribbon enabled whenever a
workbook is opened. If the Add-Ins ribbon is disabled, the BPT-specific icons will be
removed and will not re-appear until the workbook is re-opened.

e Set your Excel Macro Security Settings to “Disable all macros with notifications.”
e Enable macros when you open the BPT workbook.
e Copy BPT Add-in (BPT2024.xlam) in the C:\BPT\BPT2024 folder.

1.2.1.2 Installing the Add-in File

The CY2024 BPT is comprised of the following three Microsoft Excel file types:

1. Working BPT Files: MA, PD, MSA and ESRD-SNP (.xIsm files)
2. Finalized BPT Files: MA, PD, MSA, and ESRD-SNP (.xlIsx files)
3. Macro code: BPT Add-In (.xlam file).
The BPT workbook file contains the BPT worksheets in which bid pricing is calculated based on

user-entered data. The BPT Add-in contains the code that supports the BPT workbook
functionality.



CY2024 Bid Pricing Tool Technical Instructions

The BPT workbooks and the BPT Add-in files can be downloaded as part of the Plan Benefit
Package (PBP) software or as separate stand-alone files:

The BPT workbooks and the BPT add-in files can be downloaded with the PBP software, which
contains MA, PD, MSA and ESRD-SNP benefit information. To download the BPT workbooks
as part of PBP:

1. Go to the Health Plan Management System (HPMS) website and select Plan Bids > Bid
Submission > CY 20XX > Download > Generic BPT Software (Figure 1- ) (Where ‘XX’
is your current Contract Year).

2. From the tab ‘BPT Add In & Spreadsheets’ select the checkbox for the Add In and BPTs
required.

3. Click the ‘Download’ button. An executable file, SetupPBP2024.exe will begin the
installation when executed (double-clicked).

a. Click ‘Next’ to install the file.
b. Click ‘Yes’ on the Disclaimer

C. Select the file destination and click ‘Next’. Files by default are downloaded to a
folder of your choosing; the Add-in file is saved in C:\BPT\BPT2024. (If the
BPT2024 folder does not exist, the PBP process will create it.)

d. Click ‘Install’.
e. The BPT workbooks and add-in are downloaded to C:\BPT\BPT2024 folder.

f. This installation process supports BPT data pre-population from the PBP. (See
Section 1.2.2.3, “Data Pre-population,” below.)

4. You can also download the BPT Batch Tool by selecting the ‘BPT Batch Tool’ tab and
clicking the ‘Download’ button. An executable file, will begin the installation when
executed (double-clicked).

a. Unzip the file to download to the C:\BPT\BPT2024 folder. The Add-in file must
be saved in C:\BPT\BPT2024.

b. This installation process does not support data pre-population from the PBP (i.e.,
the workbooks are blank).
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Figure 1- Download BPT Software

Bid Submission L‘ =

HPMS > Plan Bids > Bid Submission > CY 20X > Generic BPT Software

M Cya2oxx
Download Generic BPT Software

Download A

S

Plan-Specific BPTs
Manage Plans v [ pownload BPT Version Tl ReleaseDate TL  File Name Tl Notes

Upload  ~ DO Addin 20001 04/07/200 BPT20i0Cexe T oty /dd In fila s a required componant
Documentation v 0O ma 20x¢.01 04/07/20XX BPT20X(MA axe

O po 20XX.01 04/07/20%X BPT20XXPD.exe ke

O msa 20XX.01 04/07/20XX BPT20XXMSA exe

M Historical Information O Eskp

B Cveox

20XX.01 04/07/20X% BPT20XXESRD.exe

For a brief overview of the steps to install the BPT Add In and/or BPT Spreadsheets click here.

Note: You must create the C:\BPT\BPT2024 folder and save the BPT Add-in file to the BPT2024
folder. If there is an existing BPT2024.xlam file in the C:\BPT\BPT2024 folder, you must always
overwrite the existing BPT Add-in (BPT2024.xlam) file saved on your PC with the most current
version. (Do NOT move/copy the add-in to another location on your PC.) BPT’s that are prepared
by user may be stored anywhere on the user’s PC.

If you do not save the BPT Add-in file in the designated folder, you will receive a message within
the BPT workbook stating that the BPT2024.xlam (BPT Add-in) file cannot be found. The BPT

will open in read-only mode. If the BPT Add-in is not saved in the correct folder, you will not
be able to use the BPT.

The BPT add-in does not interfere with any non-BPT files.
For users that prepared BPTs for previous contract years, BPT Add-in files should be left in

place from previous years. Leave all previous contract years in their respective folders. (e.g.
C:\BPT\BPT2023 or BPT2022).
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1.2.2 Opening the BPT

1.2.2.1 Macro Security Level Setting

BPT working files and the Batch tool are supported in Excel 2016, 2019 and Excel 365 Desktop
version. Excel 2013 and Office 365 with Sensitivity Label is not supported.

1. The security setting options are “Disable all macros without notification,” “Disable all

macros with notification,” “Disable all macros except digitally signed macros,” and
“Enable all macros.”

o For security reasons, it is recommended that you set the setting to “Disable all
macros with notification.”

. Under the “Disable all macros with notification” setting, the workbook will open with a
Splash screen (i.e., a static information screen) and you will see an Option button and a
message: “Security Warnings. Macros have been disabled.”

o You must click the Option button and select “Enable this content”.

o The workbook will then open with the Add-in loaded. The Add-in icons will be
part of the Add-Ins ribbon.

Under the “Disable all macros with notification” setting, it is possible that the workbook
will open and be editable without the Add-in loaded. This may be due to previous Excel
instances that were not closed correctly.

o In this situation, you must select “Enable this content” to load the add-in.

o Do NOT save any changes in the workbook until you select the “Enable
Macros” option.

o The BPT file will not function properly until the Add-in is loaded (when all add-in
icons appear on the Add-in toolbar.)

4. Note: Please work with your IT/IS department to ensure you have adequate permission to

configure the settings as shown and run macros in your environment.

o Go to > File > Options > Trust Center > Trust Center Settings > Macro Settings.
Select settings as shown in Figure 2 - An Excel Macro Settings.
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Figure 2 - An Excel Macro Settings
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Figure 3 - Active X Settings
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1.2.2.2 Version Compatibility

You will be able to open and work with multiple BPT files in the same Excel instance. If you want
to close a BPT file and open another one, you should also close Excel and open the next BPT
file in a new instance of Excel. If you encounter any issues when opening a BPT file, then close
Excel, go to the Task Manager, delete any other Excel processes, and then open a BPT file in a
new Excel window.

Working files for prior years such as CY2023, CY2022 along with CY2024 working files will
NOT work properly in the same Excel instance (i.e., window). You must open separate
instances of Excel in order to work with a CY2024 working BPT file and a CY2023 working BPT
file at the same time.

10
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Note: It is not sufficient to close a CY2023 working BPT prior to opening a CY2024
workbook within the same instance of Excel. The CY2024 workbook MUST be opened in a
different instance of Excel by closing Excel before opening the CY2024 workbook. Otherwise
you will encounter a “subscript out of range” error. This error will disappear once you close the
CY2023 instance and re-open the CY2024 instance. See Figure 2.2.2-A.

You must open the working files for the same contract year in the same Excel instance; otherwise
you will receive an error message stating that the BPT Add-in file is read-only because it is already
open in another Excel instance.

Note: These restrictions only apply to working versions of BPT workbooks. You will be able to
open a read-only file, such as a finalized or backup file (CY2023 or CY2022) and a working file
in the same Excel instance.

For returning BPT users (e.g., those that used the CY2023 BPT), you may receive the following

error message upon opening the CY2024 BPT for the first time you access the CY2024 BPT. See
Figure 4 - BPT Add-in Error.

Figure 4 - BPT Add-in Error

BPT Addin Error X

There was a general error when attempting to open the workbook,
! . Add-Ins may not be loaded successfully.

- Uncheck any previcus contract year BPT Add-Ins. [Ge to File »
Options = Add-Ins = Go » Add-Ins Available = Select only

BFT2012 xlam (Uncheck all previous contract year BPT Add-Ins). Click
UK.
- Avoid opening two different contract year BPT workbooks
simultanecusly or in the same Excel instance,

For further guidance, refer to the BPT technical instructions manual.

oK

If this error occurs, select file menu > Options > Add-Ins > Manage: Excel Add-Ins then click
“Go”. In the Add-Ins dialog box, un-check the “BPT2023” and select BPT2024 and click “Ok”.
This will resolve the error when opening the CY2024 BPT thereafter.

For further help with errors when opening the BPT files, see 1.4 Troubleshooting and FAQ.

1.2.2.3 Data Pre-population

When you use PBP software to download the BPT workbooks, the download process automatically
populates (or pre-populates) some of the workbooks’ “General Information” sections (Worksheet

11
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1, Section I) from the PBP. (The “General Information” entered in Worksheet 1 appears in the
header sections of all the other worksheets in the BPT workbooks.) Pre-population, however,
occurs only once. If pre-populated information in the header section is inaccurate, you can
manually update the data in the BPT. The yellow highlighted cells in the header section of
Worksheet 1 are unprotected to allow you to change values if necessary.

Note: After the data pre-population, any information updated on the HPMS website or PBP will
not be automatically reflected in the BPT. You must update the BPT manually to maintain data
consistency.

If you download a blank BPT directly from HPMS, the “General Information” section will be
blank. It is recommended that you enter this information before entering other data.

1.2.2.4 BPT Commands

Upon successfully opening a working BPT with the macros enabled, ten BPT-specific icons will
appear in the Add-Ins tab. These icons are only available if the Add-Ins is enabled. If you reset the
Add-Ins to its default setting, the BPT icons will disappear and you must close the workbook and
reopen to restore them. Clicking on the BPT icons triggers some of the workbooks’ special BPT-
specific commands. You can also invoke these commands from the File menu or using the
following short-cut key combinations. See Figure 5 - Add-in Menu Functions.

These functions are located in the Add-In menu on the Toolbar.

Figure 5 - Add-in Menu Functions

MEN 42 YJB QN

Icon names (from left to right):
e Finalize BPT: Ctrl+Shift+S
e Circle Invalid: Ctrl+Shift+C
e BPT Refresh: Ctrl+Shift+R
e Validation Report: Ctrl+Shift+l
e Hide/Unhide Non-Validation Input Cell Label: Ctrl+Shift+L
e Hide/Unhide Rate Book(s): Ctrl+Shift+B
e Enable Protected Excel Functions: Ctrl+Shift+K
e Hide/Unhide Validation Cell Label: Ctrl+Shift+M
e Print Defined Worksheets: Ctrl+Shift+P
e Hide/Unhide Formula Worksheet: Ctrl+Shift+H

12



CY2024 Bid Pricing Tool Technical Instructions

1.2.3 Populating the BPT working file

BPT workbooks are the vehicles through which organizations present their plan bids to CMS.
Users populate working files by entering required data into specified data-entry fields, and the
workbook automatically calculates and displays the results in its calculated fields. (For details on
how the workbooks calculate results, see the CY2024 BPT Instructions for MA, PD, MSA and
ESRD-SNP workbooks located in HPMS.)

1.2.3.1 Data Entry and Cell Formats

Data entry fields are highlighted in yellow. For most fields, data entry follows Excel’s “General”
format, i.e., character input is stored as text and numerical input is stored as a number. The
following four fields, however, are numerical fields that the BPT ultimately stores as text.

e PlanID
e Segment
e Region

e County Code

If data in these fields are entered as numbers, they will display as numbers until the workbook is
finalized. (Note: the finalization process (see 1.2.4.1) must be successful for these changes to
occur.) To manually enter these fields as text, users should use a leading apostrophe (') and include
any leading zero’s when entering these values. (For example, to display 030 in the Plan ID field,
enter apostrophe, zero, three, zero.) When the “General Information” data is pre-populated from
the PBP (see 1.2.2.3), the formatting automatically inserts a leading apostrophe (') and displays the
leading zero’s in these fields.

If you copy and paste cells in any of the BPT worksheets, it is recommended that you use
Excel’s PASTE SPECIAL feature with the PASTE VALUES or PASTE FORMULAS
option. This will prevent overwriting a cell’s predefined format, which can occur when the
standard PASTE command is used. Also, do not use Excel’s “Cut” function in the BPT workbooks
as it will remove the cell’s predefined formatting.

Note: It is recommended that you use the Delete key instead of the Space bar to delete cell values
from the BPT.

1.2.3.2 Cell Validation

The yellow-highlighted data entry fields fall into three categories with respect to cell validation:
validation fields, critical validation fields, and non-validation fields. Validation fields have cell-
specific rules regarding the types and format of data that can be entered into them; the rules appear
in message boxes called cell labels when the cell is highlighted. Because some cell labels partially
obstruct the user’s view of the cell, cell label displays can be turned off (see Section 1.2.3.5,
“Hide/Unhide Validation Cell Label”) or moved by clicking and dragging.

13
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If cell validation rules are not followed, a red circle will appear around the cell. (See Section
1.2.3.3, “Circle Invalid.”) If the user edits the data in the cell to bring into compliance with the
rule, the red circle will disappear; however, this does not apply to linked cells. (See Section
1.2.3.10, “Enable Protected Excel Functions™). Users can view a list of all failed validations in a
workbook by running a Validation Report. (See Section 1.2.3.4, “Validation Report.”)

Critical validation fields are validation fields whose rules must be followed before the workbook
can be successfully finalized. (See Section 1.2.4.1, “Finalization Process.”) Critical validation
rules are different for each of the BPT workbooks; they are listed in Appendix A, “Critical Errors.”

Note: Some calculation fields are validation fields. Users cannot modify calculation cells. To
address failed validations in calculation fields, users must modify the data-entry cells to which the
calculation field formulas refer.

Non-validation fields are data-entry cells that have no validation rules to display. They do not
create red circles or messages in the Failed Validation Report.

If the worksheet is hidden, the cells that have validations in the hidden worksheets will not appear
in the Validation Report.

1.2.3.3 Circle Invalid

The Circle Invalid function identifies cells that may contain invalid data; it can be invoked by

clicking the Circle Invalid icon (-=.) on the toolbar or by pressing Ctrl+Shift+C. This function
places a red circle around all failed validations in the workbook. If the user edits the data in a cell
to bring into compliance with the rule, the red circle will disappear; however, this does not apply
to linked data (See Section 1.2.3.10, “Enable Protected Excel Functions.”). The Circle Invalid
function executes automatically upon opening, saving and finalizing a BPT workbook.

Although red circles disappear when corrective data is manually entered into a cell, it is
recommended to click the Circle Invalid icon frequently to re-validate all the cells in the workbook.

1.2.3.4 Validation Report

The Validation Report function creates a new worksheet that lists all the failed validations in the

workbook; it can be invoked by clicking the Validation Report icon ( % ) on the toolbar or by
pressing Ctrl+Shift+l. This function creates two reports: the Failed Validation Report and the
Active Cell Validation Report.

The Failed Validation report identifies, for every cell in the workbook with validation errors, the
worksheet name, cell location, cell value, input message and whether or not the error is a critical
error by indicating “PASSED” or “FAILED” in the Critical Error column (FAILED critical errors
will prevent the workbook from finalizing). You cannot modify the report, but you can copy and
paste its contents into another document.

Note: Only critical errors will display “PASSED” or “FAILED” in the Critical Error column.

14
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The Validation Report function will also trigger the Circle Invalid function. If you generate the
Validation Report, you will also generate the red circles in the workbooks.

The Active Cell Validation Report assists vision-impaired users who use a screen reader. It reports
the validation status (Passed, Failed or No Validation) for the active cell on which the cursor is
placed.

The Validation Report worksheet is hidden when you save, close, or finalize a BPT. You can re-
generate the report by re-invoking the function.

If a user enters data by linking to another Excel workbook, these links must be refreshed prior to
running the Validation Report. (See Section 1.2.3.9, “BPT Refresh.”)

1.2.3.5 Hide/Unhide Validation Cell Label

The Hide/Unhide Validation Cell label function turns off the cell labels (pop-up messages that
display a cell’s validation rules) for all validation cells, including input and calculated cells in the

workbook; it can be invoked by clicking the Hide/Unhide Validation Cell Label icon ('@ ) on the
toolbar or by pressing Ctrl+Shift+M. By default, cell labels are turned on for validation cells.

Note: This function controls turning on and off input messages for validation cells only. The cells
that do not have validations cell label input messages are controlled by the Hide/Unhide Non-
Validation Input Cell Label function. (See section 1.2.3.6 “Hide/Unhide Non-Validation Input Cell
Label function.”)

1.2.3.6 Hide/Unhide Non-Validation Input Cell Label

The Hide/Unhide Non-Validation Input Cell Label function turns on the automatic display of cell
labels for non-validation cells, which enables screen readers to read the contents of the cell label’s
message; it can be invoked by clicking the Hide/unhide Non-Validation Input Cell Label icon (

= ) on the toolbar or by pressing Ctrl+Shift+L. All cells that do not have validations will display

a pop-up input message with the cell location and cell label. When you click on a cell, the screen
reader will read the cell’s message which indicates whether the cell is an input cell. For example,
if this function is invoked and the user clicks on cell G27 in Worksheet 1 of the MA BPT
(MA1.Ill.a (g)), the following message will be read by the screen reader: “G27 Input Cell
Annualized Utilization/1000 for Inpatient Facility”. By default, non-validation cell messages do
not automatically appear when a BPT file is first opened.

1.2.3.7 Hide/Unhide Rate Book(s)

The Hide/Unhide Rate Book(s) function allows you to hide or unhide the Rates worksheet (MA,
MSA, and ESRD-SNP BPTs) and the Statutory Rates worksheet (MA BPT only); it can be invoked

by clicking the Hide/Unhide Rate Book(s) icon () on the toolbar or by pressing Ctrl+Shift+B.
These worksheets will be hidden in the finalized BPT file. You will be able to copy and paste the
data to another document prior to finalization.
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1.2.3.8 Hide/Unhide Formula Worksheet

The Hide/Unhide Formula Worksheet function allows you to hide or unhide a worksheet which
displays the formulas for all formula cells in the BPT file (except for hidden formula cells); it can
be invoked by clicking the Hide/Unhide Formula Worksheet icon (%) on the toolbar or by pressing
Ctrl+Shift+H. The Formula sheet is hidden by default and protected from user modification. These
worksheets will be hidden in the finalized BPT file.

1.2.3.9 BPT Refresh

The BPT Refresh function updates a BPT workbook’s links to other Excel workbooks; it can be
invoked by clicking on the BPT Refresh icon (Er? ) on the toolbar or by pressing Ctrl+Shift+R.
BPT Refresh automatically executes upon opening or saving a BPT workbook.

Data entered in some cells (independent cells) affects the status of other cells (dependent cells).
For example, if Plan Type is “RPPO,” then MA Region will be editable (and a drop-down menu
will appear); if Plan Type is other than “RPPO,” then MA region will not be editable (and “N/A”
will appear). If the value of Plan Type is entered in the workbook directly, the status of MA Region
will be updated whenever Plan Type is modified. However, if the value in Plan Type is linked to
an external Excel file and the external file is modified, BPT Refresh must be invoked in order to
update the status of MA Region.

The following list describes dependent fields—along with the independent fields they depend on—
that require BPT Refresh when links are involved as described above. (For further details about
the relationships between these fields, see the line-by-line instructions in the MA and PD BPT
Instructions.)

e Plan Type on MA Worksheet 1 Cell G7

o If the Plan Type is RPPO, the MA Region field is editable; otherwise it is protected
and displays N/A.

o If the Plan Type is RPPO, the MA Benchmark Plan Bid Component (W5, M17) is
editable; otherwise the field is protected and displays N/A.

o If the Plan Type is RPPO, the Enrollee Type (W1, K5) is protected and displays
A/B.

e MA-PD indicator on MA Worksheet 1 Cell G8 and Plan ID on Worksheet 1 D6

o If Plan ID is less than 800 and MA-PD indicator is “No”, the MA Bid Summary
Plan Intention for target Part D basic premium (W6 R47) is protected and displays
a value of “N/A — MA only plan”), and any values in the cells are removed.

o IfPlan ID is less than 800 and the MA-PD indicator is “Yes”, MA W6 R47 contains
a drop-down list.
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©)

If Plan ID is greater than or equal to 800, MA W6 R47 will be protected and display
“N/A - EGWP bid”. Part D premium and rebate cells also become protected, and
any values in the cells are removed.

Plan Type on PD Worksheet 1 Cell 16

o

©)

If the Plan Type is PDP, cell F32 on PD Summary (w7) is editable and has a drop-
down list displaying values 0.10 and 0.50; for all other plan types, this cell is
protected and displays the value 0.10.

If the Plan Type is PDP, ED PDP or Fall Back, the Enrollee Type field (w1 17) is
protected. Otherwise, this cell is editable.

PD Benefit Type on PD Worksheet 1, N6

o

(@]

O

o

O

If the PD Benefit Type is EA, PD worksheet 4 is hidden;
If the PD Benefit Type is DS, both PD worksheet 4 and 5 are hidden;
If the PD Benefit Type is BA, PD worksheet 4 is hidden;
If the PD Benefit Type is AE, PD worksheet 5 is hidden.

If the PD Benefit Type is DS, PD worksheet 6 columns I, J, K in section Il are
shaded and protected.

Use of ISAR factor on MA Worksheet 5 Cell G31

o

If the ISAR factor is “Yes”, cells G39 to G3333 are editable; otherwise these cells
are protected.

MA Plan ID on MA Worksheet 1 Cell D6

o

If the Plan ID is equal to or greater than 800, the employer PMPM input on
Worksheet 4, cell R116 is editable; otherwise it is protected.

If the Plan ID is greater than or equal to 800, the Overall Gain/(Loss) Margin Level
will be white, protected, and display “Contract.” Otherwise field is editable and
displays a drop-down list with “Contract,” “Organization,” and “Parent
Organization.”

Plan level In-Network OOP Max on MA Worksheet 3 Cell G12

©)

If the OOP Max indicator G12 is ”Yes”, then H12 is editable; and when G12 is
”No” H12 is protected.

Plan level Out-of-Network OOP Max on MA Worksheet 3 Cell J12
o Ifthe OOP Max indicator J12 is ”Yes”, then K12 is editable; and when J12 is

”No”, K12 is protected.
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e Plan level Combined OOP Max on MA Worksheet 3 Cell M12

o Ifthe OOP Max indicator M12 is ”Yes”, then N12 is editable; and when M12 is
”No”, N12 is protected.

e SNP on MA Worksheet 1 K8 —
o If the SNP indicator K8 is “Y”, then O8 is editable; and when K8 is “N”, O8 is
protected and displays “N/A.”

Note: The BPT Refresh does not run the BPT validation rules. Use the Circle Invalid function or
Validation Report function if you want to refresh the red-circle display.

1.2.3.10 Enable Protected Excel Functions

The Enable Protected Excel Functions function allows the user to access a list of Excel functions
(Change Link, Trace dependents, Trace precedents, Trace error and Remove all arrows) that are
disabled because the BPT worksheets are protected; these functions can be invoked using this BPT
feature.

You can invoke this function by clicking the Enable Protected Excel Functions icon (%) on the
standard Excel toolbar or by pressing Ctrl+Shift+K. The system will then:

1. Display a toolbar under the standard toolbar, See Figure 6 - Protected Excel Functions
Toolbar:

Figure 6 - Protected Excel Functions Toolbar

i 2w ali a2 2 @ Links...

2. Allow the user to click one of these icons to display the corresponding Excel screen for
that function.

You can click the Enable Protected Excel Functions icon (.%.) again to hide this toolbar.

The Change Link function allows you to change the link source using the standard Excel Edit link
function. The Trace dependents, Trace precedents, Trace error and Remove all arrows functions
are standard Excel functions used for formula auditing and cell tracing. Once enabled, these items
function as they do in a standard Excel workbook.

1.2.3.11 Print Defined Worksheets

The Print Defined Worksheets function allows you to print pre-defined worksheets in a BPT; it

can be invoked by clicking the Print Defined Worksheets icon (5;' ) on the Toolbar or by
pressing Ctrl+Shift+P. The pre-defined worksheets are:

e MA - Worksheets 1, 2, 3, 4, 6 and the first page of worksheet 5

e PD - All visible worksheets (which varies based on benefit type)
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MSA - Worksheets 1, 2, 4 and the first page of worksheet 3
ESRD-SNP — Worksheets 2, 3, and the first page of worksheet 1

Note: This function does not print the validation report; it can be printed manually.

1.2.3.12 MA, MSA, and ESRD-SNP County Code Section

County Codes are entered in the following workbook sections:

MA worksheet 5, rows 39 to 3333 columns B through U
MSA worksheet 3, rows 39 to 3333 columns B through H
ESRD-SNP worksheet 1, rows 21-320 columns A through |

The following macro functions are applicable to these sections:

1.

The MA and MSA workbooks support up to 3,295 lines of county codes. The ESRD-SNP
workbook supports 300 lines of county codes.

County codes must be entered in consecutive rows starting with row 39 (row 21 for the
ESRD-SNP workbook). Row 39 contains the formulas in a blank BPT.

All county codes in Column B for both MA and MSA workbooks and Column A for
the ESRD-SNP workbook must be entered as a 5 digit number preceded by an
apostrophe (*). (See Section 1.2.3.1, “Data Entry and Cell Formats.”) “#N/A” errors
appear if values are entered incorrectly. You cannot successfully finalize a file if there are
errors in the county code field. You must correct these errors to finalize the BPT.

When a county code is entered in column B (column A in the ESRD-SNP workbook), the
macros automatically populate formulas in the following cells:

a. Columns C, D and H in the MA workbook.
b. Columns C, D, G, and H in the MSA workbook.
¢c. Columns B and G in the ESRD-SNP workbook.

Note: F must be entered into the ESRD Status column (D) in the ESRD-SNP workbook for the
County Name column (C) to populate with County Name data. A valid county code must be
populated in column A for this to be applicable.

5.

6.

When a county code is deleted from column B (column A in the ESRD-SNP workbook),
the macro removes the automatically populated formulas in the cells described above.

All county codes are sorted in the finalized file in descending order. (See Section 1.2.4.1,
“Finalization Process.”)

If the county codes are imported as a batch from another tool and they include spaces or
special characters, these spaces and special characters are sorted as non-blank rows. As a
result, you may see some blank lines in the finalized file at the top of the county code
section. Open the working files, remove these lines, and re-finalize the BPT.
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8. For each row in the MA, MSA, and ESRD-SNP County Code sections ([MA5.VI1.3],
[MSAS.111.2],and [ESRD-SNP1.11] respectively), these conditions must be met for
finalization to be successful:

a. If there is a non-zero value in the Projected Member Months field (column E), then
there must be non-zero values in the County Code field (column B for MA and
MSA, column A for ESRD-SNP) and the Projected Risk Factor field (column F)
for the corresponding row.

b. If there is a non-zero value in the Projected Risk Factors field (column F), there
must be a non-zero number in the County Code field (column B for MA and MSA,
column A for ESRD-SNP) in the corresponding row.

1.2.3.13 Undo Function

The BPT supports the Excel undo functionality with some exceptions. Modifying any of the cells
listed below cause the actions/states stored in your undo history to be deleted. This means that
after entering, changing, or deleting a value in any of the following cells, you cannot undo your
previous actions.

e Plan Type

e MA-PD indicator

e PD Benefit Type

e Use of ISAR factor

e County Codes

e Any cell with a drop-down box

e Any cell that has a validation error removed due to a correction in the user entered data

A new undo history begins to compile after each of these cells are modified.

1.2.3.14 Save Functions

There are two save processes available within the BPT: a non-finalized and a finalized save.

A non-finalized save can be invoked by clicking on the Excel Save icon on the Quick Access
toolbar or by selecting File and then save from the Excel menu. This save process saves any
changes you have made to the BPT workbook.

A finalized save occurs when the “Finalize BPT” function is invoked (See Section 1.2.4,
“Finalizing the BPT for Submission”). This step is taken when the workbook is complete and ready
for upload to HPMS.
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1.2.4 Finalizing the BPT for submission

The Finalize BPT function prepares the workbook for submission to HPMS; it can be invoked by

clicking the Finalize BPT icon (SP*" ) on the toolbar or by pressing Ctrl+Shift+S. You must finalize
your workbooks before packaging them with the PBP data for upload to HPMS.

Before you finalize a BPT file, do the following:

1.

If you have the Latest add-in, please ensure that it is disabled prior to finalization of
the BPT

Click the Validation Report or Circle Invalid function to check for any critical
errors. If critical errors are not corrected, you will receive an error message and the BPT
file will not finalize.

A validation report is included in finalized versions so that the user can view red circle
and failed validations after finalization.

1.2.4.1 Finalization Process

When the finalization function is triggered, the system performs the following actions:

Recalculate the BPT working file.

o Note: The Excel settings of the BPT include Automatic Calculation of formulas.
Users have the ability to change the BPT’s Excel settings, from Automatic
Calculation to Manual Calculation, by selecting File>Options>Formulas. However,
please note that when a user attempts to finalize the BPT - even if the finalization
is unsuccessful due to the failure of critical validations — then the Excel settings of
the BPT working file are changed back to Automatic Calculation. The Automatic
Calculation is reset during any attempted finalization (whether successful or not).

Check the required fields—certain fields (e.g., “Contract Number””) must be entered for
finalization to be successful; these fields are listed in Appendix B, “Required Fields”.

Check the critical validations—critical validation fields must comply with their validation
rules for the finalization process to be successful; the fields are listed in Appendix A,
“Critical Errors”. To locate critical errors, create and view a Validation Report; the critical
errors display “PASSED” or “FAILED” in the Critical Error column. All critical errors
must be corrected for a file to be successfully finalized.

Save the working file.

Create a backup file—this is a read-only file that contains the same data as the working
file; it can be used to restore data in a working file. (See Section 1.3.7, “Use the Backup
File to Restore a Prior Version of the BPT.”)

Create an XML file — These files are created upon successful finalization of a BPT.
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o

(@]

The XML filename will appear in the following format: Contract Number, Plan
ID, Segment ID, and Workbook Type.

Example: H1234123001MA.xml

e The XML file is not to be modified after finalization of the BPT and must be uploaded
alongside the finalized BPT .xlsx file of the same name.

e Create a finalized file with the following features:

(@]

Designated fields (Plan ID, Segment ID, Region, County Codes) are padded with
a leading apostrophe and leading zero’s to display the required number of digits For
example, if you entered 2 for Plan ID, the finalized file contains ‘002 (See Section
1.2.3.1, “Data Entry and Cell Formats™).

All PD worksheets display in the finalized file, but only the applicable worksheets
based on the PD Benefit type contain data. For example, if you selected BA as the
Benefit type, and entered data in PD Worksheet 5, and then later change the Benefit
type to AE, the data entered in Worksheet 5 will be deleted. (For further information
on which worksheets are applicable for which PD Benefit Types, see the Part D bid
instructions).

County Codes ([MA5.V1.3], [MSA3.1I1.2], and [ESD-SNP1.1l) are sorted in
descending order. Note: The data in the working file and the backup file retains the
original (pre-sorted) order.

During finalization, a “timestamp” footnote is added within the finalized BPT.
(MA WS6 cell B57, PD WS7 cell B49, MSA WS4 CELL E69, ESRD-SNP WS2
cell A102)

Formulas are removed in the finalized file. Formulae in the working file and the
backup file remain.

PD Region [PD1.1.10] is saved as “N/A” in the finalized file if PD Region in the
working file is left blank. The region field in the working BPT remains blank.

Red circles display for cells that do not pass validation rules. Note: You can finalize
the file if the red circled cell is not one of the critical errors. A list of critical
validations for each workbook is in Appendix A, “Critical Errors.”

Rate sheets are hidden. In the working file you can still unhide the Rate sheets as
needed.

A Validation Report is available for the user to view red circle and failed
validations.

The Working Text Box is removed from the finalized file (MA Worksheet 6 and
PD Worksheet 7) but remains in the working file and the backup file.
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o All data in H25:H64 and M25:M64 on MA Worksheet 3 will be removed during
the finalization process. Data will remain in the working and backup versions.

o The finalized file only contains the BPT worksheets, the BPT Information Sheet
and the splash screen.

1.2.4.2 File Naming Convention

Finalized BPT workbooks are saved using the following standardized naming convention:
Contract ID+Plan ID+Segment ID+Workbook Type.xIsx. Use of this convention is a requirement
for a successful bid upload to the HPMS and enables the Plan Benefit Package software to validate
your bid submission file. //TODO

Example: H1234123001MA.xIsx

Note: Finalized files are saved in the same directory where the working file is located.

Backup files use the same naming convention as finalized files with a timestamp appended to the
end of the name: finalized filename + * Backup "+YYYY-MM-DD-HHmmss.xlsm

Example: H1111001001MA_Backup_ 20XX-5-20-100000.xlsm
Note: Back up files are saved in the same directory where the working file is located.

The working file name can be changed at any time. The finalized and backup BPTs are read-only
files. If you need to make additional changes prior to bid submission (i.e., prior to upload to
HPMS), modify the working file and finalize the BPT again; the previous finalized file will be
overwritten. A new backup file will be created; backup files will not be overwritten (as they are
time-stamped). (For guidance on using backup files to recover saved data, see Section 1.3.7, “How
to use the backup file to restore a prior version of the BPT.”)

1.2.5 Closing the File

When you exit a BPT file by closing the workbook or by closing Excel, the system will check to
see if any changes have been made since the last save. If there have been no changes, the file will
close. If there have been changes made since the last save, you will receive the following message
prompt: “Any unsaved information will be lost. Would you like to save the changes to your
<filename>?" If you click—

Yes—the BPT file will be saved and closed.

No—the BPT file will be closed without saving changes.

Cancel—the pop-up message disappears and the file will not be closed nor saved.

1.2.6 Password Protection

The BPT is password protected. You may not modify the structure of the BPT workbooks or
worksheets. Each data item must be located in its pre-defined cell location for successful
processing by the HPMS.
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Tampering with the BPT protection, including but not limited to un-protecting and re-
protecting any parts of a BPT workbook will permanently compromise the file and prevent
successful finalization of that BPT workbook.

If a workbook is compromised in this way, you must discard the compromised BPT, download
and complete a new BPT.

1.2.7 Print Functionality

The workbooks contain a BPT-specific Print button that will print a pre-defined set of worksheets
(with print areas and page setups pre-designated). (See Section 1.2.3.11, “Print Defined
Worksheets.”)

The standard Excel Print function (select File then Print) will print the current worksheet using the
BPT-designated print areas and page setups. Multiple worksheets may be printed by clicking
multiple tabs while holding down the Ctrl key or the Shift key) and then invoking the standard
Excel Print function.

To bypass the BPT-designated print areas and page setup, set these parameters as you would in
Excel and then invoke the standard Excel Print function.

1.2.8 New Releases

If necessary, the Centers for Medicare and Medicaid Services may deploy a new version of the
BPT Add-in file to update the BPT workbooks. The new version will be made available to the user
community through HPMS. HPMS will send an auto-generated email to certain HPMS users to
announce that a new BPT Add-in is available for download from HPMS.

If CMS deploys an updated version of the BPT Add-in (BPT2024.xlam) file, you must download
this file from the HPMS website. You must overwrite the existing BPT Add-in with the most
current version in the C:\BPT\BPT2024 folder. If you saved multiple versions of the BPT Add-
in to the BPT2024 folder or elsewhere on your personal computer (PC), you may experience
technical difficulties with the BPT.

Note: If you receive the BPT add-in file via email and it is saved to your temporary directory as
part of the email download process, you must delete it from the temporary directory.

To verify that the BPT workbooks are using the latest version of the Add-in file, compare the
version number given during the add-in download process to the version number in the upper right
corner of Worksheet 1 of the BPT (e.g., “MA-2024.4” indicates that the BPT is using version 4 of
the add-in).

You will need to update all of your BPT workbooks (MA, PD, MSA, and ESRD-SNP) with the
latest BPT add-in file. If you have finalized a BPT with an old version of the add-in file but not
yet uploaded it, you must download the new Add-in file, update the working file, and re-finalize
the BPT.
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The BPT workbook is updated automatically when first opened after downloading the new BPT
Add-in file. When you receive a pop-up message stating that the BPT is out of date, click “OK”
and the update process will begin. As part of the update process, a backup version of your previous
BPT will be saved to a C:\BPT\BPT2024\Update Backup VersionX folder, where X is the Add-in
file version number.

You will not need to transfer any data from one workbook to another to apply a BPT Add-in
update. For step-by-step instructions on downloading an add-in file update, see Section 1.3.3,
“How to Update the BPT Add-In” and Section 1.3.4, “How to Update the Add-In for Multiple
BPT Workbooks using the Batch Tool.”

1.2.9 Batch Process Tool

The Batch Process Tool is supported in Excel 2016, 2019 and Excel 365 Desktop version only.
The Batch Tool is not supported in Excel 2013. BPT does not support the Excel 365 Online version
or Excel 365 with Sensitivity label.

A Batch Process Tool is available to assist you with updating, finalizing and checking validation
errors for multiple BPT workbooks. The estimated execution time for the process can vary greatly
based on your PC’s processing power, the number of workbooks in the batch, the size of each
workbook (e.g., MA workbooks with a large number of county codes may experience slower
execution time). It is recommended that you initially run a small batch (e.g., five to ten workbooks)
to assess the execution time specific to your PC. The Batch Process Tool is available for download
from the HPMS Bid Submission module. You must close all BPT workbooks before running
the batch process. During the batch process an Excel file may open during executions. Do not
attempt to close, alter or edit the Excel file until the batch completes its function. Doing so could
result in errors while processing the selected batch function. After the batch process is completed,
close the Batch Process Tool and any open Excel files before opening a stand-alone BPT file (to
avoid potential conflicts between the files).

Note: You must have Excel 2016, 2019 or Excel 365 Desktop version installed to use the Batch
Process Tool. Reports will be generated in the .xlIsx format.

All batch processes will skip (i.e., will not process) the following files if they are selected:

e Non-BPT Excel workbook
e Backup BPT file
e Finalized version of BPT
e Working BPT with different contract year (e.g., CY2023 working file)
Before using the Batch Process Tool, make sure the following boxes are checked: “Trust access to

the VBA project object model” (Options>Trust Center>Trust Center Settings>Macro Settings)

Note: The Batch Process Tool will set the BPT Calculation flag (click File>Options>Formulas)
to “Automatic.” To choose a different setting (after the batch process completes), open a
stand-alone BPT workbook and manually change the setting.
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1.2.9.1 Batch Validation Report

This function will generate validation reports for one or more BPT files. To enable this function,
launch the Batch Process Tool, select “Validation Report,” and click “Next.” See Figure 7 - Batch
Tool Validation Report. Select the BPT files (with file extension .xlsm) to be processed. The
Batch Process Tool will disable all icons that may disrupt its execution. The execution status of
the batch process will be displayed in the Batch Process Tool status window. A success or failure
message is displayed for each of the BPT workbooks. At the end of the process, you will receive
a message confirming the number of files that passed, failed or were not processed. The report will
be saved in the same folder from which the BPT files were selected. The report is saved in the
xIsx format. The report’s Index Page lists the filenames, Contract IDs, Plan I1Ds, and Segment IDs
associated with the report. A hyperlink next to each file will take you to the corresponding report
worksheet.

Figure 7 - Batch Tool Validation Report

a5 Bid Pricing Tooel - Batch Process o | =] &R

Bid Pricing Tool - Batch Process Keyboard Mavigation Instructions, will open in a new window

* |f the BPT file version is lower than the version of the add-in file, the batch will update the BPT file version to be in sync with the
add-in version.

Select Process Option

Q) Validation Report Create the validation report *

i Version Update Update the BPT version to be consistent with the version of the add-in file
i@ Finalize BPT Finalize the BPFT working file *

@ Update PD National Avg  Insert National Average values into PD *

i Update PD Prem in MA Copy the PD Premiums from PD and paste into the comesponding MA =

Note: If the BPT files selected to be processed were created with an older Add-in file version
than the batch process uses, the files will be updated first before being processed by the
batch. (See Section 1.2.9.2, “Batch Update Process.”)

1.2.9.2 Batch Update Process

If a new version of the BPT Add-in is downloaded from HPMS, the Batch Process Tool will allow
you to update all of your working BPT files to the latest BPT add-in version. To enable this
function, launch the Batch Process Tool, select the “Version Update” option, and then click
“Next.” See Figure 8 - Batch Tool Version Update. Select the BPT files (with file extension
XxIsm) to be updated with the new version of the BPT add-in, and then click “Update” to start the
batch process. The Batch Process Tool will disable all icons that may disrupt its execution. The
execution status of the batch process will be displayed in the Batch Process Tool status window.
A success or failure message is displayed for each of the BPT workbooks. If any updates fail, an
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associated error message will be displayed. When the process is complete, you will receive a
message indicating the number of files that passed, failed or were not processed. The updated files
will be saved in the same folder from which they were selected. (For further instructions, see
Section 1.3.4, “How to Update the Add-In for Multiple BPT Workbooks Using the Batch Tool.”)

Figure 8 - Batch Tool Version Update
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= If the BPT file version is lower than the version of the add-in file, the batch will update the BPT file version to be in sync with the
add-in version.

Select Process Option

-:i Validation Report Create the validation report *

& Version Update Update the BPT version to be consistent with the version of the add-in file
@ Finalize BPT Finalize the BPT working file *

i Update PD National Avg  Insert National Average values into PD *

i Update PD Prem in MA Copy the PD Premiums from PD and paste into the comesponding MA *

To verify that the BPT workbooks are using the latest version of the Add-in file, compare the
version number given during the add-in download process to the version number in the upper right
corner of the BPT worksheets (e.g., “MA-2024.1" indicates that the BPT is using version 1 of the
Add-in).

1.2.9.3 Batch Finalize Process

You can use the Batch Process Tool to finalize multiple BPT workbooks. Launch the Batch Process
Tool, select “Finalize BPT,” and then select the BPT files (with file extension .xIsm) to be
finalized; click “Finalize” to start the batch process. During the process, the execution status will
display in the Batch Process Tool status window. The Batch Process Tool will disable all icons
that may disrupt its execution. A success or failure message will display for each of the workbooks
processed, and an error message will display for each workbook that fails finalization. When the
process is complete, you will receive a message indicating the number of files that passed, failed
or were not processed. The finalized files will be saved in the same folder from which they were
selected.
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Figure 9 - Batch Tool Finalize BPT
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* |f the BPT file version is lower than the version of the add-in file, the batch will update the BPT file version to be in sync with the
add-in version.

Select Process Option

@ Validation Report Create the validation report *

# Version Update Update the BPT version to be consistent with the version of the add-in file
i Finalize BPT Finalize the BPT working file *

i Update PD National Avg  Insert National Average values into PD *

i Update PD Prem in MA Copy the PD Premiums from PD and paste into the comesponding MA *

Note: If the BPT files selected to be finalized are at a lower version of the add-in file, the files
will be updated first and then finalized.

1.2.9.4 Batch Update PD National Average Process

You can use the Batch Process Tool to update the PD “National Average Monthly Bid Amount”
[PD7.1I1.2] in multiple PD workbooks. Launch the Batch Process Tool and select the “Update PD
National Average” option. See Figure 10 - Batch Tool Update PD National Avg. In the two input
fields, enter the “National Average Monthly Bid Amount” [PD7.111.2] and the “Base Beneficiary
Premium” [PD7.111.3] and then select the PD BPT files (with file extension .xIsm) to be updated;
click the “Update National Avg” button to start the batch process. During batch processing, the
system will write the two input values into the selected PD files.
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Figure 10 - Batch Tool Update PD National Avg
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* |f the BPT file version is lower than the version of the add-in file, the batch will update the BPT file version to be in sync with the
add-in version.

Select Process Option

@ Validation Report Create the validation report *

# Version Update Update the BPT version to be consistent with the version of the add-in file
@ Finalize BPT Finalize the BPT working file *

Q) Update PD National Avg  Insert National Average values into PD *

i Update PD Prem in MA Copy the PD Premiums from PD and paste into the comesponding MA *

The Batch Process Tool will disable all icons that may disrupt its execution. The execution status
of the batch process will be displayed in the Batch Process Tool status window. A success or failure
message is displayed for each of the BPT workbooks. If any workbooks fail to be finalized, an
associated error message will display. When the process is complete, you will receive a message
indicating the number of files that passed, failed or were not processed.

A report will be generated and saved in the same folder from which the PD files were selected.
The report will be generated in the .xlsx format. In the report, you will see the file names for all
files that were successfully updated. The report will also display the “Basic Part D Premiums,
Rounded” [PD7.111.5] before and after the updates for each workbook.

This batch process will ignore the following files if selected:

e Non-BPT Excel workbook

e MA, MSA and ESRD-SNP workbook types

e Backup BPT file

e Finalized BPT file

e Working BPT with different contract year (e.g., CY2022 working file)
e PD workbooks with blank Contract Number, Plan ID values.

The report will list ignored files in the section titled, “The following files were not updated
because they are not valid CY2024 PD files or contain blank Contract and Plan IDs”.
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1.2.9.5 Batch Update MA BPT with PD Premiums

You can use the Batch Process Tool to copy the Basic and Supplemental Rounded PD Premiums
([PD7.111.5] and [PD7.111.7], respectively) from multiple PD workbooks into the corresponding
MA workbooks with the same Contract-Plan-Segment IDs ([MAG6.111.C.7a] and [MAG.111.C.84a],
respectively). To do this, launch the Batch Process Tool, select “Update MA with PD Premiums,”
and then select the PD workbooks to be used in the update. See Figure 11 - Batch Tool Update
Prem in MA. On the bottom file selection window, select the MA workbooks that you want to
update with the PD premiums. Click the “Update MA with PD Premiums” button to start the batch
process. The batch process will copy premium values from the PD workbook(s) into the
corresponding MA workbook (i.e., the MA file with the same Contract Number, Plan ID and
Segment ID).

Figure 11 - Batch Tool Update Prem in MA
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* If the BPT file version is lower than the version of the add-in file, the batch will update the BPT file version to be in sync with the
add-in version.

Select Process Option

-:i Validation Report Create the validation report *

# Version Update Update the BPT version to be consistent with the version of the add-in file
i Finalize BPT Finalize the BPT working file *

@ Update PD National Avg  Insert National Average values into PD *

Q) Update PD Prem in MA Copy the PD Premiums from PD and paste into the comesponding MA *

The Batch Process Tool will disable all icons that may disrupt its execution. The execution status
of the batch process will be displayed in the Batch Process Tool status window. A success or failure
message is displayed for each of the BPT workbooks. If any workbooks fail to be finalized, an
associated error message will display. When the process is complete, you will receive a message
indicating the number of files that passed, failed or were not processed.

A report will be generated and saved in the same folder from which the MA files were selected.
The report will be generated in the .xIsx format. The report will list the PD workbooks—and the
corresponding MA workbooks—that were successfully updated. In each processed MA workbook,
you will see the PD Premium values ([MAG.111.C.7a] and [MAG.111.C.8a]) both before and after
the updates. Duplicate MA workbooks (i.e., one with the same Contract, Plan and Segment ID as
another MA workbook) will also be updated with the PD premiums and displayed in the top section
of the report. The following files will be ignored by this process:
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Duplicate PD workbooks (i.e., one with the same Contract, Plan, and Segment ID as
another PD workbook that has already been processed) will not be processed and will be
displayed in the report under the section titled: “The following PD files were not processed
because they are a duplicate to a processed PD file”. That is, the PD premiums in the
duplicate PD BPT will not be copied into the corresponding MA BPT via the Batch Process
Tool.

MA workbooks that do not match any selected PD workbooks (based on Contract Number,
Plan ID and Segment ID) will not be processed and will be displayed in the section titled:
“The following MA files were not matched to the selected PD source files”. That is, the
PD premiums in the MA BPT will not be updated / changed during the batch process.

PD workbooks that do not match any selected MA workbooks (based on Contract Number,
Plan ID and Segment ID), will not be processed and will be displayed in the section titled:
“The following PD files were not matched to the selected MA target files”. That is, the PD
premiums in the PD workbook will not be copied into any MA workbooks during the batch
process.

The system will also ignore the following files; they will be reported in the section titled: “The
following files were not processed because they are not valid CY2024 MA or PD files™:

Non-BPT Excel workbooks

MSA and ESRD-SNP workbooks

Backup BPT files

Finalized BPT files

Working BPT files with different contract year (e.g., CY2019 working files)

MA or PD workbooks with blank Contract Number, or Plan ID values.

1.2.9.6 Batch Process Termination Handling

If the Batch Process Tool is terminated abnormally before the process is completed, you must close
all Excel instances (i.e., windows) before you re-run the batch process. (See Section 1.3.8, “How
to re-start the Batch process if it is abnormally terminated” for detailed instructions)

1.2.10 Accessibility Features

The Bid Pricing Tool provides features that allow you to work with BPT files using a keyboard
and screen reader. See details in the sections below for features applicable to the workbooks and
the Batch Process Tool.

1.2.10.1 Workbook Accessibility Features

The following are accessibility features available for the BPT workbooks:
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Default location for active cursor upon opening a workbook — The active cursor is located
in the worksheet’s title cell (MA W1 B2, PD W1 B2, MSA W1 B2, and ESRD-SNP W1
Al). This allows you to have the same starting point every time the document is opened.
It also allows screen reader users to know the worksheet title information upon opening a
BPT file.

Tabbing through active input cells — While using a working BPT file, you can use the
Tab key to navigate directly to the editable input cells (yellow-shaded cells).

BPT-specific functions — Alternative text and shortcut keys are available for you to
access the specific functions available in the standard Excel toolbar. See Section 1.2.2.4
for more information.

Validation Report — The validation report lists all failed validations. It allows you to use
the screen reader to access failed validation information without relying on the red circles
displayed on the workbooks. See Section 1.2.3.4 for more information.

Hide/Unhide Non-Validation Input Cell Label — This function assists vision-impaired
users who use screen readers when working with BPTs. It allows you to turn on or off the
input cell labels (input messages that display the cell labels) for all non-validation cells.
See Section 1.2.3.6 for more information.

Hide/Unhide Validation Cell Label - This function assists vision-impaired users who use
screen readers when accessing validation cells, including both input cells and protected
formulae cells. It allows you to turn on or off the input cell labels (input messages that
display the validation rules) for all validation cells. See Section 1.2.3.5 for more
information.

Hide/Unhide Formula Worksheet — This function assists vision-impaired users who use
screen readers when accessing cell formulae. It allows you to hide or unhide a worksheet
that displays formulae for all formula cells. See Section 1.2.3.8 for more information.

1.2.10.2 Batch Process Tool Accessibility Features

The following are the accessibility features available for the Batch Process Tool:

When you first open the Batch Process Tool, the cursor defaults to the Keyboard
Navigation Instructions button, which displays instructions about navigating throughout
the application using the keyboard. See Figure 12 - Keyboard Navigation Instructions.

The Keyboard Navigation Instructions contain the following information:

NOTE: If the version of the BPT file is older than the version of the Add-in
(BPT2024.xlam) file, the batch process will first update the BPT file and then
proceed with the selected process.
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Figure 12 - Keyboard Navigation Instructions
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MNOTE: If the version of the BPT files is older than the version of the add-in file, the batch
process will first update the BPT file and then proceed with the selected process.
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To select a batch process use the Up and Down arrows or the following key stroke
combinations:

. Validation Report: Press ALT +V

. Version Update: Press ALT + U

. Finalize BPFT: Press ALT + F

. Update PD National Average: Press ALT + D

. Update Part D Premium in the MA Workbook: Press ALT + P
. Keyboard Nawigation Instructions: Press ALT + K

00N P D0 I —

After choosing the process, press the Tab key once and then select one of the following
options: o

Close

To select a batch process, use the Up and Down arrows or the following key stroke
combinations:

Validation Report: Press ALT +V

Version Update: Press ALT + U

Finalize BPT: Press ALT + F

Update PD National Average: Press ALT +D

Update Part D Premium in the MA Workbook: Press ALT + P

Keyboard Navigation Instructions: Press ALT + K

o a s~ e

After choosing the process, press the Tab key once and then select one of the following
options:
1. To go to the next window for the process selected, press ALT + N
2. To exit the tool, press ALT + X
If the Next option is chosen, the next window will default the cursor on the Keyboard
Navigation Instructions. To execute the process for the target file or files, conduct the
following steps:
1. Press the Tab key twice to focus on the Select Folder section

a. For the PD National Average process

i. Press the Tab key once to populate the National Average Monthly
Bid Amount

ii. Press the Tab key once again to populate the Base Beneficiary
Premium

iii. Press the Tab key once again to focus on the Select Folder section
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5.

b. For the Update MA with PD Premiums process
i. Press the Tab key twice to focus on the PD Select Folder section

ii. Use the Up and Down arrows and the Enter key to navigate to the
target parent and subfolder

iii. Press the Tab key once to focus on the Select File section
iv. Press the Tab key to select the file or files
v. Press the Tab key twice to focus on the MA Select Folder section

Use the Up and Down arrows and the Enter key to navigate to the target parent
and subfolder

Press the Tab key once to focus on the Select File section
a. Press the Tab key twice to return to the first screen of the tool
b. Press the Tab key three times to exit the tool

Select the file or files to be processed by using the Up and Down arrows and
pressing the Spacebar to highlight the file

Press the Tab key once and press the Enter key to execute the process

Once the process is complete, a dialog box will pop up and provide a summary of the
files that were successfully or unsuccessfully processed. To view the Debug log or
report, select “Yes.” To exit the dialog box, select “No.” Selecting “No,” will display
the recent process screen. At this point, the same process can be run by following the
steps above, another process can be run by pressing Alt + R, or the tool can be exited
by pressing Alt + E.

1.3 How To...

1.3.1

Download a Blank Stand-alone BPT Workbook

1. Gotothe HPMS Website and select Plan Bids > Bid Submission > CY 2024 > Download>
Generic BPT Software.

2. Select the Add-in and required BPTSs.
3. Click Download.

4. When prompted to “Save” or “Run” the download file, choose “Save” and select a folder
in your directory.
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1.3.2 Download and Launch the Batch Process Tool

1.

Create a directory on your workstation to save the batch tool, e.g., C:\BPT\BATCH2024.
For Microsoft 365, the Desktop version must be used to download the batch to the C:\.

If you have previously downloaded the batch tool, remove the older version prior to
downloading the newer version by deleting any files in the chosen directory.

Go to the HPMS Website and select Plan Bids > Bid Submission > CY 2024 > Download
Bid Software.

Select “BPT Batch Tool”.

5. Click the ‘Download’ button.

6. When prompted with “Run”, “Save”, “Cancel” the file "BatchApplication.zip", choose
Save and select your chosen directory to save the file on your computer.

7. Double-click the left mouse button on the "BatchApplication.zip" file name to open the zip
file. Extract the files within the selected directory.

8. Double-click the left mouse button on "BatchBPTApplication.exe" file to launch the batch
application. Do not click on the other supporting files in the folder other than the
BatchBPTApplication.exe. See Figure 13.

Figure 13 - Batch Tool Executable File
h :,:Ba T - o /o

This PC > (C)OSDisk > BPT » BATCH 2022 > bin

1.3.3 Update the BPT Add-In

1.

In Windows Explorer, navigate to the C:\BPT\BPT2024 folder.
Delete the existing BPT2024.xlam file if applicable.

3. Go to the HPMS Website and select Plan Bids > Bid Submission > CY 2024 > Download

Bid Software.
Select “BPT Add-in & Spreadsheets”.
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. Read the instructions and click the ‘Download’ button to begin the process.
6. Save the file in the C:\BPT\BPT2024 folder.
7. Open a BPT and select “Enable Macros”. (This one is applicable only if Macro security is

set to “Disable all macros with notification”.)

. Click “OK” when you see the following message: “The current version of this BPT file is

version x. This is not the most update to date version. Updating to versiony.”

. Verify that the BPT has been updated to the newer version by checking the version number

in the upper right hand corner of Worksheet 1: cell N3 (for PD workbooks), cell Q3 (for
MA workbooks), cell P3 (for MSA workbooks) or cell C1 (for ESRD-SNP workbooks).
The number after the period reflects the current version (e.g., MA-2024.1 indicates the
BPT is using version 1 of the Add-in).

1.3.4 Update the Add-In for Multiple BPT Workbooks

Using the Batch Tool

Double-click the BPT Batch Process icon or the BPT2024 BatchProcess.exe file name to
start the application (after downloading the batch file per Section 1.3.2, above).

On the Select Process Option screen, select “Version Update”.
Click “Next”.

Using the files search window, locate the folder where you saved the BPT workbooks
(i.e., the “.xIsm” files).

Select the workbooks to update. (Use the Shift key or the Ctrl key to select multiple files.)
Click “Update™.
Review success or failure messages for the selected workbooks.

Verify that the workbooks have been updated to the newer version by checking the version
numbers in the upper right hand corner of Worksheet 1: cell N3 (for PD workbooks), or
cell Q3 (for MA workbooks), cell P3 (for MSA workbooks) or cell C1 (for ESRD-SNP
workbooks).

1.3.5 Finalize an Individual BPT Workbook

. Open a completed BPT workbook.
. Select “Enable Macros” when prompted. (Only applicable if Macro security is set to

“Disable all macros with notification”.)

. Invoke the Finalize BPT function by clicking the icon on the tool bar, selecting “Finalize

BPT” from the File menu, or pressing Ctrl+Shift+S.

If you receive any critical validation error messages, you must resolve the errors before
attempting to re-finalize your BPT. (See Section 1.2.4.1, “Finalization Process” for more
detail on the finalization process.)
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5.

Verify that the working file is saved in the designated folder and that the finalized backup
files are created in the same folder.

1.3.6 Finalize Multiple BPT Workbooks Using the Batch

Tool

Double-click the BPT Batch Process icon or the BPT2024 BatchProcess.exe file name to
start the application (after downloading the batch file per Section 1.3.2, above).

On the Select Process Option screen, select “Finalize BPT”.

3. Click “Next”.

>

© N o o

Using the files search window, locate the folder where you saved the BPT workbooks (i.e.,
the “.xIsm” files).

Select the workbooks to update. (Use the Shift key or the Ctrl key to select multiple files.)
Click “Finalize”.
Review success or failure messages for the selected BPTSs.

Verify that the working files are saved in the designated folder and that the finalized and
backup files have been created and saved in the same folder.

1.3.7 Use the Backup File to Restore a Prior Version of the

BPT

If the working version of the BPT has been corrupted, or you need to roll back to a prior version
of your BPT, restoring a backup version of your BPT may be necessary.

1.

o~ W

In Windows Explorer, locate the backup file in the same directory where the working file
is saved.

Right-click on the backup file name.

Select “Rename” from the menu.

Remove the word Backup from the file name and click enter.

Open the file, verify that the Add-in has loaded and the file is editable.

1.3.8 Re-start the Batch Process if it is Abnormally

Terminated

1.

Save and close any open non-BPT Excel workbooks.
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Press Ctrl+Alt+Delete to launch the Task Manager, select the Processes tab, and then click
the “Image Name” column to sort the processes names.

Select EXCEL.EXE and click the “End Process” button. If more than one EXCEL.EXE
process is found, repeat this step to end all the EXCEL.EXE processes.

Close the Task Manager.

Double click the BPT Batch Process application icon or the BPT2024 BatchProcess.exe
file name to re-start the Batch Process.

1.3.9 Update PD National Averages in Multiple PD files

1.

Double click the BPT Batch Process icon or the BPT2024 BatchProcess.exe file name to
start the application (after downloading the batch file per Section 1.3.2, above).

On the Select Process Option screen, select “Update PD National Average”.
Click “Next”.

Enter values in the input fields for the National Average Monthly Bid Amount and the Base
Beneficiary Premium.

Using the files search window, navigate to the location where you saved PD workbook
(.xIsm) files.

Select the PD files. You can use the Shift or Space key to select multiple files.
Click the “Update PD National Average” button.
Review success or failure messages for the selected BPTSs.

After the process completes, verify that the PD files are updated correctly. A report will be
available in the same folder where the PD files are located.

Also, see Section 1.2.9.4, “Batch Update PD National Average Process.”

1.3.1 Update Multiple MA Files with PD Premiums

1.

Double click the BPT Batch Process icon or the BPT2024 BatchProcess.exe file name to
start the application.

On the Select Process Option screen, select “Update PD Premiums in MA™.

Click “Next”.
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4. Using the top files search window, navigate to the location where you saved PD workbook
(.xIsm) files.

5. Select the PD files. You can use the Shift or Space key to select multiple files.

6. Using the bottom files search window, navigate to the location where you saved MA
workbook (.xIsm) files. Note: The MA files should match to the PD files selected above
(same Contract Number, Plan ID and Segment ID).

7. Click the “Update PD Premiums in MA” button.
8. Review success or failure messages for the selected BPTs.

9. After the process completes, verify that the MA files are updated correctly. A report will
be available in the same folder where the MA files are located.

Also, see Section 1.2.9.5, “Batch Update MA BPT with PD Premiums.”
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1.4 Troubleshooting and FAQ

1.4.1

Problems with the Add-In File

If you are having difficulty opening, saving or finalizing a BPT, check to see if more than one
copy of the CY2024 Add-in file is saved on your PC. To ensure you only have the latest copy of
the CY2024 Add-in file stored in the correct location, perform the following:

1.

2.

Delete all BPT2023.xlam files saved in C:\BPT\BPT2023

Download the BPT2024.xlam file from the HPMS website and save it in the
C:\BPT\BPT2024 folder. (See Section 1.2.1.2, “Installing the Add-in File.”)

Confirm that the macro security setting is set to “Disable all macros with notification”.

a.
b.
C.

d.

Open an Excel window.
Click File>Excel Options>Trust Center>Trust Center Settings>Macro Settings.
Verity that the macro setting is “Disable all macros with notification”.

Close the Excel window.

Confirm that the Add-in is unloaded properly.

a.
b.
C.

d.

Open an Excel window.
Click File>Excel Options>Add-ins>"Go”
Verify that any prior year CY add-ins are unchecked. (i.e.: CY2023 and CY2022).

Close the Excel window.

Close all Excel windows on your PC.

Launch the Task Manager, select Processes tab, select EXCEL.EXE and click “End
Process” if applicable. Repeat for each instance of EXCEL.EXE.

Confirm that there is only one BPT add-in on the PC.

a.

b.

Click “Start”, select “Search”, and then the “For Files or Folders” option.
Enter BPT2024.xlam in the “Search” for “Files and Folders” name box.
Select Local Hard Drive C: in the Look In dropdown box.

If multiple files are found, delete the BPT2024.xlam in any other folders and keep
only one BPT2024.xlam file in the C:\BPT\BPT2024 folder.
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8.

e. Repeat step ¢ for any other local hard drives (e.g., D:\) that might contain the
BPT2024.xlam file.

Check the workbook to see if the issue is resolved.

1.4.2 Missing Add-in from the Toolbar

If you have difficulty with the Add-in or if the Add-in tab is missing from the toolbar, the Add-in
file has become corrupted or may not be configured correctly. To resolve this issue:

1.

2.

Temporarily rename or remove the Add-in file from the C:\BPT\BPTXXXX folder.
Close all Excel Files.

Open the BPT file.

Go to File> Options> Add-ins >Manage Excel Add-Ins. Click ‘Go’.

Uncheck the BPT20XX from the Add-ins list and click ‘Go’.

Rename/Replace the Add-in back to the original naming convention in the
C:\BPT\BPTXXXX folder.

Go back to the location in Step 4 and check the selection for the BPT20XX add-in and
click ‘OK’.

Confirm that the Add-in Tab in the ribbon loads correctly.

1.4.3 Frequently Asked Questions

The following contains a list of FAQs:

1.

Question: When | open a BPT file, I only see the BPT Splash Screen. Where are the
other worksheets?

Answer: You may have multiple BPTs open in separate instances (i.e., windows) of Excel or it
may be due to a corrupted Add-in file. Close all but one BPT file or re-install the Add-in file.
(See Section 1.4.1, “Problems with the Add-In File,” to re-load the Add-in file)

2.

Question: Why can’t I find the BPT commands, such as BPT Finalize, Circle Invalid
and BPT Refresh icons, on my Excel Toolbar?

Answer: The BPT icons are loaded with the ADD-INS Toolbar and they only appear when the
Add-Ins is enabled. Follow the steps below to load the Add-Ins Toolbar.
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a. On the Excel, select file menu > Options > Add-Ins > Manage: Excel Add-Ins then click
“Go”. In the Add-Ins dialog box, select BPT2024 and click “Ok”

b. Close the Excel window.

c. Open the BPT.

3. Question: | have entered multiple County Codes (MA5.VI1.3, MSA3.111.2, or ESRD-
SNPL.11), but the formulae are not copied into row 40 and below?

Answer: This may be due to the BPT add-in file not being properly loaded in the BPT. Follow
the steps in Section See Section 1.4.1, “Problems with the Add-In File,” to re-load the add-in
file.

4. Question: The Macro Security setting on my PC is set to “Enable all macros” but I don’t
see the prompt when opening the BPT. Do | need to enable the Macros in another way?

Answer: If the Macro security setting is “Enable all macros”, the BPT Add-in file will
automatically run when you open the BPT; therefore, you don’t see the prompt to enable macros.
For security purposes, it is recommended that the Macro Security Level be set to “Disable all
macros with notification”.

5. Question: | encountered the following error(s) when finalizing the BPT, what should |
do? (See any of the below errors)

There was an error when finalizing the BPT.
Error 13: Type mismatch

Figure 14 - Error Message 1 in MA BPT
X

The EPT cannot be finakzed. This error occurs because of invalid values such as "T#YALUE', "#NJA’, '#REF or text incorrectly placed into a numeric cell,
This error may occur in the county code saction:

= MA Benchmark ~ Column B rows 39-3333 county codes should be entered as a S dgit number with a leading apostrophe. Example: 01010,
It may also occur in one of the following cells:

MA Benchmark - E2S

MA Bid Summary =123, L25-129, L31, M25-M29, R16, R31, R43, R4S

Other cells in the workbook may also cause this error, Please check the workbook and make the necessary corrections before attempting to finakze.
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Figure 15 - Error Message 2 in MSA BPT
x|

The BPT cannot be finalzed. This error occurs because of invakd values such as "I #VALUE', "#NJA', '#REF or text incorrectly placed in a numeric call.
This error may occur in the county code saction:

- MSA Benchenark — Column B row 39-3333 county codes should be entered a5 3 5 digt number with a leading apostrophe, Example: 01010,
It may also occur in one of the Following cels:

M5A Benchmark ~ G336

MSA Depost and Paymt ~ H48, HS3, 148, 1S3

Other cells in the warkbook may cause this error., Please check the workbook and make the necessary corrections before attempting to finalze

[

Figure 16 - Error Message in PD BPT
x|

The BPT cannot be finalized. This error occurs because of invalid values such as ""#VALUE', "#N/A', "#REF' or text incorrectly placed into a numeric cell.

- This error might occured in W57 of PD Workbook under section: SUMMARY OF KEY BID ELEMENTS and one of the following cells: F15, F21, F25, F27,
F28, F32:

Other cells in the workbook may also cause this error. Please check the workbook and make the necessary corrections before attempting to finalize.

Answer: If you receive any of these messages, check the referenced workbook cells and verify
that they do not contain # VALUE, # N/A, # REF, text, or #DIV/0!.

If the referenced cells do contain valid values, please check the entire workbook for cells that
either contains the #ERROR message or text values instead of numeric values. These need to be
corrected before you can finalize the BPT workbook.

6. Question: I received a “subscript out of range” error. What should I do? (Figure 17)
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Fiqure 17 - BPT Addin Error

BPT Addin Error 3

There was a general error when atternpting to open the workbook.
! % Add-Ins may not be loaded successfully.

- Uncheck any previcus contract year BPT Add-Ins. [Go to File =
Options » Add-Ins = Go = Add-Ins Available » Select only

BPT2017 xlam (Uncheck all previcus contract year BPT Add-Ins). Click
QK.

- Avoid opening two different contract year BPT workbooks
simultanecusly or in the same Excel instance,

For further guidance, refer to the BPT technical instructions manual.

oK

Answer: CY2023 and CY2024 working files cannot be open in the same Excel instance (window).
Open the CY2024 working file in a different Excel instance. (Close all workbooks and all instances
of Excel. Open Excel and in the (first) instance open the CY2024 workbook. Then open a second
instance of Excel and open the CY2023 workbook. (See Section 1.2.2.2, “Version Compatibility.”)
If this does not resolve the issue, open an Excel window, Select File>Options>Add-ins>Go button
and then make sure the “BPT2022” and “BPT2023” boxes are unchecked. Open the BPT file in
this Excel window.

For returning BPT users (i.e., those that used the CY2022 BPT), you may receive this error
message upon opening the CY2024 BPT for the very first time. If this error occurs, select
File>Options>Add-ins>Go button and un-check the “BPT2023” box. Verify that the “BPT2024”
box is checked. This will resolve the error when opening the CY2024 BPT thereafter.

7. Question: I receive the following Run Time Error when opening BPT files. What should 1
do? (Figure 18)
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Figure 18 - Run Time Error

Microsoft Yisual Basic |

Fun-time error ‘1004

IUnable ko set the Inskalled property of the AddIn class

Debug Help |

Continue |

Answer: This may happen if the Excel process does not load the BPT Add-in file properly prior
to opening and saving a working BPT file in the same Excel instance.

1.

2.

Open an Excel instance.
Click File>Options>Add-ins>"Go”.
In the list of Add-ins, select the checkbox for BPT2024.

Close the existing Excel window and re-open the BPT file. If this does not resolve the
issue, follow the steps in See Section 1.4.1, “Problems with the Add-In File,” to re-load
the Add-in.

Question: | receive the following Run Time Error when opening BPT files. What should |
do? (Figure 19)

Figure 19 - Run Time Error

Microsoft Yisual Basic |

Rur-time errar ‘1004

Unable to set the Installed propertsy of the AddIn class

Debug Help |

Continue |

Answer: This may happen if the Excel process does not load the BPT Add-in file properly prior
to opening and saving a working BPT file in the same Excel instance.

1.

Open an Excel instance.
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2. Click File>Options>Add-ins>"Go”.

3. Inthe list of Add-ins, select the checkbox for BPT2024.

4. Close the existing Excel window and re-open the BPT file. If this does not resolve the
issue, follow the steps in Section See Section 1.4.1, “Problems with the Add-In File,” to
re-load the Add-in.

9. Question: | am trying to open BPT files, but I do not see the Option button. How do |
enable contents?

Answer: To enable the contents:
1. Click Click File>Options>Trust Center>Trust Center Settings
2. Click Trust Center > Trust Center Settings >Message Bar.

3. Click the first radio button below:

e Show the Message Bar in all applications when active content, such as ActiveX controls and
macros, has been blocked. This option is selected by default so that you get Message Bar
alerts whenever potentially unsafe content has been disabled. The option is not selected if
you clicked the “Disable all macros without notification” option on the Macros pane of the
Trust Center. If you click disable all macros without notification, you will not get Message
Bar alerts when macros are disabled.

e Never show information about blocked content. This option disables the Message Bar.

10. Question: Why is the Excel window in the background while Batch is running, can I close
it?

Answer: No, you cannot close, edit or alter the Excel window while the batch is running. The
Excel window is a normal process of the Batch Tool. Interfering with the Excel window can
cause errors in the batch process.

11. Question: Why do I see “Protected View” when I open the BPT file?
Answer: Protected view turns on when you try to open BPT files directly from a network folder
or an outlook email or an internet site. You should save the BPT files in local folder before

opening.

12. Question: Why do I receive the error “Error updating the BPT — 1004: Cannot access
‘filename.xlsm” when I open the BPT file?

Answer: This error may be received when the user is trying to open the BPT via a network drive

(BPT only supports local drives), the version of Microsoft Office being used is an older version
and needs to be updated, or there are insufficient user privileges to open the BPT files.
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13. Question: Why do I receive the message “Unhandled exception has occurred in your
application” If you click Continue, the application will ignore this error and attempt to
continue. If you click Quit, the application will close immediately.” Could not load file
or assembly ‘Interop.Scripting. Version=1.0.0.0 Culture=neutral. PublicKey=null’ or one
of its dependencies. The system cannot find the files specified” when I open the BPT
file?

Figure 20 - BPT Batch Process Finalization Error

N o ey e

BPT Batch Process — Finalization |£h

— Unhandled exception has occurred in your application. If you click
,'8‘, Continue, the application will ignore this error and attempt to continue.
"l If you click Quit, the application will close immediately.

Could not load file or assembly ‘Interop Scripting, Version=1.0.0.0,
Culture=neutral, PublicKeyToken=null’ or one of its dependencies.
The system cannot find the file specified.

| » Details | Continue Quit

Answer: In order to remove this error message the user needs to put all the dependency files and
.exe files together in one folder. The .exe file cannot be located in a separate folder from the
other dependency files (Figure 21)

Figure 21 - Dependency and Execution Files

= | Batch Tool - o X
Home | Share e L]
"

Delete

This PC > (C) OSDisk > BPT » BATCH 2022 > bin

3 BarchBPTApalication aplication

3 BatchBPTA,

BatchBPTA|
DEBUGLOG
erop.MSDAOSP.dI

14. Question: Why do I receive the error message “Data at the root level is invalid. Line I,
position 1” when finalizing the BPT?

Answer: This issue is caused by an interaction between the new XML encryption feature of the
BPT workbooks and the Laserfiche plugin. The plugin is attempting to automatically validate the
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XML output of the finalized BPT, but since the XML is encrypted, it does not appear valid.
Please ensure that the Laserfiche plugin is disabled prior to finalizing the BPT files.

Figure 22 - BPT Finalization Error

Error

Q Data at the root level is invalid. Line 1, position 1

OK Details Help

Error Details ﬂ

15. Question: Why do I receive the error message “Data at the root level is invalid. Line 1,
position 1 when finalizing the BPT?

Answer: This issue is caused by an interaction between the new XML encryption feature of the
BPT workbooks and the Laserfiche plugin. The plugin is attempting to automatically validate the
XML output of the finalized BPT, but since the XML is encrypted, it does not appear valid.
Please ensure that the Laserfiche plugin is disabled prior to finalizing the BPT files.
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Figure 23 - BPT Finalization Error

Error

g Data at the root level is invalid. Line 1, position 1

OK Details Help

Error Details ﬂ

16. Question: Why do | receive the error message “Run-time error 91” when opening the
BPT?

Answer: This issue is caused by multiple instances of Microsoft Excel open. Please close all
instances of Microsoft Excel and re-open the BPT file.

17. Question: Why do I receive the error message “Run-time error 50290 when opening
the BPT?

Answer: This issue is caused by when Add-In file has Add-In enabled.

Figure 24 — Run-Time Error 50290
Microsoft Wisual Basic [ STOP™ IETEC

Run-tirme error 'S0290";

Application-defined or object-defined errar

‘ End | Help

To resolve this issue:

1. Go to Click File>Options>Add-ins>"Go” (Figure 25)
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2. Unselect BPT Add-In.

Figure 25 — Add- Ins Window

Excel Options @
G . . .
enerd D View and manage Microsoft Office Add-ins.
Formulas
Proofing Add-ins
Save Name Location Type -
Language Active Application Add-ins
Acrobat PDFMaker Office COM Addin C\..0\PDFMaken\Office\PDFMOfficeAddin.dll COM Add-in
Advanced Snaglt Add-in Ci\..echSmith\Snagit 9\SnagitOfficeAddindll  COM Add-in

Customize Ribbon
Inactive Application Add-ins

Quick Access Toolbar Analysis ToolPak C\..Officel S\Library\Analysis\ANALYS32XLL  Excel Add-in

Add-Ins Analysis ToolPak - VBA Ci\..ficel5\Librany\Analysis\ATPVBAEN.XLAM  Excel Add-in =
Bpt2018 CABPT\BPT2018\BPT2018.am Excel Add-in

Trust Center Bpt2019 C:\BPT\BPT2019\BPT2019.xlam Excel Add-in
Date (XML) Ci\..es\microsoft shared\Smart Tag\MOFLDLL Action
Euro Currency Tools Ci\..flice\Office15\Libran\EUROTOOLXLAM Excel Add-in
Inquire CA\..soft Office\Office15\DCF\NativeShim.dll COM Add-in
Microsoft Actions Pane 3 XML Expansion Pack
MLR2016 Addin CAMLR\MLR20164\MLR2016.xlam Excel Add-in N
Power View Ci\..| Add-in\AdHocReportingExcelClientdll COM Add-in
Solver Add-in Ci\.\Office15\LibranASOLVER\SOLVER XLAM  Excel Add-in

Darumant Ralatad Add.inc

Add-in: Acrobat PDFMaker Office COM Addin

Publisher: Adobe Systems, Incorporated

Compatibility: No compatibility information available

Location: C\Program Files (x86)\Adobe\Acrobat 11.0\PDFMaker\Office\PDFMOfficeAddin.dll

Description:  Acrobat PDFMaker Office COM Addin

Manage: |Excel Add-ins EI

Cor J [cme |

18. Question: T am selecting the option in Batch Tool to “Update PD Premium in MA” and
getting an error.

Answer: Please follow the process under 2.1.9.5.

19. Question: Why do I receive the error message: “The add-in is with a different contract
year than the BPT files and you must place the add-in in the designated folder.” when
opening the BPT even though there are no other files on my system and the add-in is the
latest version?

Answer: If the issue is unresolved after following the steps in Section 1.4.1, the system may be
pointing to the old contract years’ add-in path.
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Figure 26 — BPT Add-in Error

BPT Add-in Error &

The add-in is with a different contract year than the BPT files and you

! . must place the add-in in the designated folder. Please obtain the
correct version of the add-in and save it in the designated folder and
open the files again

o |

. - - 4

To resolve, this issue follow these steps to clear the registry and reconfigure with the latest add-
in:

1. Temporarily rename or remove the Add-in file from the C:\BPT\BPTXXXX folder.
2. Close all Excel Files.

3. Open the BPT file.

4. Go to File> Options> Add-ins >”Go”.

5. Uncheck the BPT20XX from the Add-ins list and click ‘Go’.

6. Rename/Replace the Add-in back to the original naming convention in the
C:\BPT\BPTXXXX folder.

7. Go back to the location in Step 4 and check the selection for the BPT20XX add-in and
click ‘OK”.

8. Confirm that the Add-in Tab in the ribbon loads correctly.

20. Question: Why do I receive the error message: “The BPT20XX.xlam is currently open
with the BPT workbook(s). Please make sure that you close all the BPT workbooks before
proceeding the batch process. ” when running the batch tool? (Figure 27)

Answer: This issue can occur with multiple excel instances running and the batch tool loads the

add-in into itself rather than the BPT workbook. To resolve this issue follow these steps to clear
the registry and reconfigure with the latest add-in:

1. Close the Batch Tool and any excel instances.

2. Open the BPT file.
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8.
9.

Go to File> Options> Add-ins >”Go”.
Uncheck the BPT20XX from the Add-ins list and click ‘Go’.

Close the file and attempt the batch process again.

If the steps above do not resolve the issue, follow the additional steps on the Add-in file.

Open the Add-in file. The excel file will be blank with a gray background.
Go to File> Options> Add-ins >”Go”.

Uncheck the BPT20XX from the Add-ins list and click ‘Go’.

10. Close the file.

Figure 27 — BPT Batch Error due to Add-in

» The BPT2022.xlam is currently open with the BPT workbook(s).
Please make sure that you close all the BPT workbooks before
proceeding the batch process,

0K |

21. Why do I receive the error message: “Run-time error -2147221080 (800401a8)

Automation error” when running the batch tool? (Figure 28)

Answer: This message can occur when running a large batch process. To resolve:

1.

2.

Click ‘End’ on the message.

The files will continue to process in the Batch tool.
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Figure 28 — BPT Batch Run-time Error due Processing Large Number of Files

Microsoft Visual Basic

Run-time error '-2147221080 (800401a8)":

Automation error

End Help

22. Question: When running the Batch tool, why do I receive the error message: “ERROR
OCCURS ---CHECK C:\BPT\BPT20XX|BPT Batch|DEBUG.LOG " followed by a
message in the DEBUG LOG ‘Error loading type library/DLL. (Exception from

HRESULT: 0x80029C4A (TYPE_E_CANTLOADLIBRARY)) : 48°? (Figure 29 and
Figure 30)

Answer: This message can occur when there has been a recent update to Microsoft Office/Excel
where there are duplicate registries or removed registries. To resolve:

1. Repair the MS Office install using the repair tool such as ‘Office 365 Repair 16.x - Quick
Repair Install’ to resolve any registry issues.
2. If this does not resolve the issue, remove and re-install MS Office.

3. If there are 2 versions of excel running on the system, uninstall the older one, and repair
the most recent installation afterwards.
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Figure 29 — BPT Batch Tool Error in Debug Log for MS Office Upgrade

Finalize Process X

, ERROR OCCURS --- CHECK C:\BPT\BPT 2023\BPT
] . Batch\DEBUG.LOG for more details. |

Figure 30 — BPT Batch Tool Error due to MS Office Upgrade

Error loading type library/DLL. (Exception from HRESULT: Bx88829C4A (TYPE_E_CANTLOADLIBRARY)) : 48
6/14/20822 12:49:11 PM -

6/14/2622 12:49:11 PM - --- END TRAPPED

6/14/2622 12:49:11 PM -

6/14/2822 12:49:27 PM - ERROR OCCURS --- see above for more details.
6/14/2022 12:49:27 PM -

6/14/2022 12:49:27 PM - Checking BeforeExit...

6/14/2022 12:49:27 PM -

23. Question: When opening the BPTs in Office 365, why are the add-ins not loading? Or
Why do I receive the following error message when opening the BPT in 365 “The BPT
add-in cannot be loaded when set to read-only or when being used by another BPT
program or Excel window.” Or Why do | receive the following error message when
opening the BPT in 365 “ The workbook BPT20XXMA .xIsm is in read-only mode.
Please change this property if you would like to modify the BPT.”

Answer: This message can occur if your organization has added a Sensitivity label to the Office

365 Excel. The BPTs, BPT add-in and Batch Tool do not support the Office 365 Sensitivity label
as it creates a security conflict. To resolve:

1. Please work with your organization to receive an exception for the Office 365 Sensitivity
label policy on Excel while working with the BPTs/BPT add-in and BPT Batch Tool.
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1.4.4 Support

If you need additional assistance, please call the HPMS Help Desk at 1-800-220-2028 or email
them at hpms@cms.hhs.gov.
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